FTDI Community

Please login or register.

Login with username, password and session length.
Advanced Search  

News:

Welcome to the FTDI Community!

Please read our Welcome Note

Technical Support enquires
please contact the team
@ FTDI Support


New Bridgetek Community is now open

Please note that we have created the Bridgetek Community to discuss all Bridgetek products e.g. EVE, MCU.

Please follow this link and create a new user account to get started.

Bridgetek Community

Author Topic: FT4222: issue with GPIO 2 & 3 simultaneously with I2C in mode 0  (Read 157 times)

MS

  • Newbie
  • *
  • Posts: 1
    • View Profile
FT4222: issue with GPIO 2 & 3 simultaneously with I2C in mode 0
« on: December 11, 2018, 02:35:20 PM »

Hi,

I want to use the GPIO2 and GPIO3 simultaneously with the I2C interface in CNFMODE0.

for the configuration of the ports I have used the following procedure:

- initialization of interface A as I2C master
- suspend out deactivated
- wakeup interrupt deactivated
- initialization of interface B for usage of the GPIO

I did not get the GPIO's to work. I2C works fine.
Logged

FTDI Community

  • Administrator
  • Full Member
  • *****
  • Posts: 190
    • View Profile
Re: FT4222: issue with GPIO 2 & 3 simultaneously with I2C in mode 0
« Reply #1 on: December 13, 2018, 04:30:58 PM »

Hello,

Please see our GPIO software examples provided with the library download:

.\LibFT4222-v1.4.2\samples

Unfortunately we don't have any LabVIEW examples for FT4222H.

I would recommend testing out our C programming GPIO example before continuing with LabVIEW.

Please ensure that you are using the latest LibFT4222 version (currently v1.4.2 for Windows).

If you have any further questions, you can contact us on support1@ftdichip.com.

Best Regards,
FTDI Community
Logged