FTDI Community

Please login or register.

Login with username, password and session length.
Advanced Search  

News:

Welcome to the FTDI Community!

Please read our Welcome Note

Technical Support enquires
please contact the team
@ FTDI Support


New Bridgetek Community is now open

Please note that we have created the Bridgetek Community to discuss all Bridgetek products e.g. EVE, MCU.

Please follow this link and create a new user account to get started.

Bridgetek Community

Author Topic: Unable to detect "USB Serial Port" for FT260 using UMFT260EV1A  (Read 428 times)

daboomdigity

  • Newbie
  • *
  • Posts: 1
    • View Profile

Hi,

I am working on evaluating the FT260 for the dual purpose of UART and I2C.  I am currently having issues with with having the device show up in device manager as a COM Port.  The device does show up as a "HID Compliant Device". 

I have installed the latest drivers (v2.12.28) from the FTDI website.  Does the FT260 show up on host as a COM Port?  I have tried the connecting the UMFT260EV1A to both a windows 7 and windows 10 system.


Thanks,

« Last Edit: May 29, 2019, 07:40:49 PM by daboomdigity »
Logged

FTDI Community

  • Administrator
  • Sr. Member
  • *****
  • Posts: 282
    • View Profile
Re: Unable to detect "USB Serial Port" for FT260 using UMFT260EV1A
« Reply #1 on: May 30, 2019, 11:09:45 AM »

Hello,

The FT260 is a HID class device and as such it does not generate a Virtual COM Port like our Vendor class serial devices do (for example the FT232R). As such to interface with the FT260 you can use standard HID class reports or our helper library, LibFT260.

https://www.ftdichip.com/Support/Documents/AppNotes/AN_394_User_Guide_for_FT260.pdf
https://www.ftdichip.com/Support/Documents/AppNotes/AN_395_User_Guide_for_LibFT260.pdf

Best Regards,
FTDI Community
Logged