FTDI Community

Please login or register.

Login with username, password and session length.
Advanced Search  

News:

Welcome to the FTDI Community!

Please read our Welcome Note

Technical Support enquires
please contact the team
@ FTDI Support


New Bridgetek Community is now open

Please note that we have created the Bridgetek Community to discuss all Bridgetek products e.g. EVE, MCU.

Please follow this link and create a new user account to get started.

Bridgetek Community

Author Topic: Issue with FT4232 and serial coms  (Read 150 times)

Mikexx

  • Newbie
  • *
  • Posts: 1
    • View Profile
Issue with FT4232 and serial coms
« on: December 12, 2019, 05:27:26 PM »

Using the FTDI supplied libraries I am using a delegate of the function FT_Write where the arguments are checked for being non-null.

If the processor attached to the ports of this FT4232 goes AWOL my application gets stuck in a loop. I assume the TX line must be stuck and high or low and producing a 'Break'. Either way the port is not accepting data.

An exception occurs and the following gets output to the  console:
  "Object reference not set to an instance of an object"

Is there a way of interrogating whether the device with the device associated with 'ftHandle' is accepting data?

Logged

FTDI Community

  • Administrator
  • Sr. Member
  • *****
  • Posts: 352
    • View Profile
Re: Issue with FT4232 and serial coms
« Reply #1 on: December 13, 2019, 11:38:32 AM »

Hello,

Would it be possible to see the section of code your application is getting stuck at?

You may want to look at the FT_Timeouts function in the API:
https://www.ftdichip.com/Support/Documents/ProgramGuides/D2XX_Programmer's_Guide(FT_000071).pdf

Best Regards,
FTDI Community
Logged