FTDI Community

Please login or register.

Login with username, password and session length.
Advanced Search  

News:

Welcome to the FTDI Community!

Please read our Welcome Note

Technical Support enquires
please contact the team
@ FTDI Support


New Bridgetek Community is now open

Please note that we have created the Bridgetek Community to discuss all Bridgetek products e.g. EVE, MCU.

Please follow this link and create a new user account to get started.

Bridgetek Community

Author Topic: FT602ChipConfigurationProg.exe Communication Error  (Read 109 times)

AndreiBu

  • Newbie
  • *
  • Posts: 1
    • View Profile
FT602ChipConfigurationProg.exe Communication Error
« on: March 31, 2020, 10:39:57 AM »

Hello,
1) I have connected the UMFT602A-B module to my computer with an USB3.0 cable. I followed the steps in AN_435 and AN_437 on how to use the FT602 Configuration Programmer and how to install the driver and Microsoft Visual C++ 2013 Redistributable (x86) package. The program runs on Windows 10 64-bit machine.
The UMFT602A-B is powered from USB with the default jumper configuration (no changes to the board).
When I execute the FT602ChipConfigurationProg.exe program, all buttons and text boxes are disabled except for Read From File and Read Configuration buttons as shown in FT602ChipConfigurationProg_1.JPG picture attached. If I click on one of the two buttons then all the buttons and text boxes are enabled, see FT602ChipConfigurationProg_2.JPG attached.
I select the FIFO Mode as 245 Mode from the combo box and click on Write Configuration button then I get a device communication error as depicted in FT602ChipConfigurationProg_3.JPG.
I click on the Auxiliary Interface check button and all the buttons and text boxes are disabled in General Config tab. Click on FIFO Channel 1 tab and I'm trying to write again the configuration by clicking on the Write Configuration button, I get the device communication error message as depicted in FT602ChipConfigurationProg_4.JPG. I click on the Switch to Advanced Mode button on the same page and then the application exists.
I can see the device installed in the Device Manager.

2) When I plug the UMFT602A-B module to the Altera Cyclone V GX Starter KIT running the program as described in AN_434 then I can see the video pattern stream in VLC. I can't write the configuration using FT602ChipConfigurationProg.exe in this case also.

I can't write the configuration to the device using the FT602ChipConfigurationProg.exe, can you please help me with this problem?
Logged