FTDI Community

Please login or register.

Login with username, password and session length.
Advanced Search  

News:

Welcome to the FTDI Community!

Please read our Welcome Note

Technical Support enquires
please contact the team
@ FTDI Support


New Bridgetek Community is now open

Please note that we have created the Bridgetek Community to discuss all Bridgetek products e.g. EVE, MCU.

Please follow this link and create a new user account to get started.

Bridgetek Community

Author Topic: UMFT4222EV not sending/received I2C (Win 10)  (Read 348 times)

allenhuffman

  • Newbie
  • *
  • Posts: 15
    • View Profile
UMFT4222EV not sending/received I2C (Win 10)
« on: April 24, 2020, 12:41:27 AM »

I have two UMFT4222EV modules that used to work great, but now I can't get either to receive or send I2C using the same code that worked great a few months ago.

The only thing I can think that changed was a fresh reinstall of Windows since then.

My test app lists all the FTDI devices (FT4222 A and B, twice, since I tried plugging both in to make them talk). It can get clock speed and address and everything looks fine.

But nothing is coming out -- I've hooked it up to a logical analyzer and also a scope. Nothing on Clock/Data.

I've tried removing the driver and reinstalling. It's bound to be a "strange windows thing."

Anyone encountered this?


Logged

FTDI Community

  • Administrator
  • Sr. Member
  • *****
  • Posts: 443
    • View Profile
Re: UMFT4222EV not sending/received I2C (Win 10)
« Reply #1 on: April 27, 2020, 04:59:04 PM »

Hello,

Please try a complete FTDI driver uninstall / reinstall with the following document instructions:

FTDI_Driver_Uninstall_with_2-12-28_Install.pdf

Otherwise there is something else going on with your setup.
Maybe some other people on the FTDI community has experienced this sort of issue before?

Also you are in contact with our US Support team. Feel free to post any resolution here to help other community users.

Best Regards,
FTDI Community
Logged