FTDI Community

Please login or register.

Login with username, password and session length.
Advanced Search  

News:

Welcome to the FTDI Community!

Please read our Welcome Note

Technical Support enquires
please contact the team
@ FTDI Support


New Bridgetek Community is now open

Please note that we have created the Bridgetek Community to discuss all Bridgetek products e.g. EVE, MCU.

Please follow this link and create a new user account to get started.

Bridgetek Community

Author Topic: Can't build or run the example for LibMPSSE-SPI downloaded from the FTDI website  (Read 136 times)

Archer6906

  • Newbie
  • *
  • Posts: 1
    • View Profile

Hi,

I have downloaded the LibMPSSE 0.6 Source from the FTDI website, but I got an error when running the SPI example as below,

==============================================
chris@chris-HP-ProDesk-490-G3-MT-Business-PC:SPI$ . b.bash
------------------------------------------------
in function getArch
STR = 64
ARCH = x86_64
------------------------------------------------
----------------------------------------
Please select the sample application to build and run
1. SPI-Static
2. SPI-Dynamic
3. Test all
1
------------------------------------------------
Building sample by linking to static library and running it
sample-static.c: In function ‘main’:
sample-static.c:290:31: warning: cast from pointer to integer of different size [-Wpointer-to-int-cast]
    printf("  ftHandle=0x%x\n",(unsigned int)devList.ftHandle);/*is 0 unless open*/
                               ^
sample-static.c:296:40: warning: cast from pointer to integer of different size [-Wpointer-to-int-cast]
   printf("\nhandle=0x%x status=0x%x\n",(unsigned int)ftHandle,status);
                                        ^
/usr/bin/ld: i386 architecture of input file `libMPSSE.a(ftdi_spi.o)' is incompatible with i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `libMPSSE.a(ftdi_infra.o)' is incompatible with i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `libMPSSE.a(ftdi_mid.o)' is incompatible with i386:x86-64 output
collect2: error: ld returned 1 exit status
bash: ./sample-static.o: No such file or director
==============================================

It looks  like there is no libMPSSE.a for x86_64 (My OS is Ubuntu 18.04 64-bit, Kernel 5.3.0-46-generic) in the ../Release/lib/linux directory. And even I tried to build the libMPSSE.a, there is no Makefile to build it.

Could you help to provide the libMPSSE.a for x86_64 PC and the Makefile that can be used for building it as well?

Thanks.
« Last Edit: April 27, 2020, 01:02:01 PM by Archer6906 »
Logged

FTDI Community

  • Administrator
  • Sr. Member
  • *****
  • Posts: 412
    • View Profile

Hello,

We don't have a 64-bit version included with our Linux built at the moment but we are currently working on a build for 64-bit Linux. We should have a beta version soon and will let you know when it is available.

Best Regards, FTDI Community
Logged