General Category > Test and Review Area

FTDIUSBSerialDriver_v2_4_4 (macOS)

(1/2) > >>

FTDI Community:

Customers using macOS 10.15 Catalina have been experiencing signature issues with FTDI's VCP driver.
The following driver should resolve these issues:


Please let us know if you have any feedback on this driver by either posting here or emailing us at

Best Regards,
FTDI Community


I am facing the issues still with this version. I am on macOS Catalina 10.15.5.

If you need any input from my side to provide more value, let me know and I will support.

sudo kextutil /Library/Extensions/FTDIUSBSerialDriver.kext
Untrusted kexts are not allowed
Kext with invalid signature (-67050) denied: /private/var/db/KernelExtensionManagement/Staging/tmp.MOlSZN/F1E8F36B-1CB8-4356-919C-90DD52584F6C.kext
Bundle (/Library/Extensions/TrimDriver.kext) failed to validate, deleting: /private/var/db/KernelExtensionManagement/Staging/tmp.MOlSZN/F1E8F36B-1CB8-4356-919C-90DD52584F6C.kext
Unable to stage kext (/Library/Extensions/TrimDriver.kext) to secure location.
    Dependency lacks appropriate value for OSBundleRequired and may not be available during early boot: - Safe Boot

(kernel) Notice - new kext, v1.2 matches prelinked kext but can't determine if executables are the same (no UUIDs).

I am having the same issue as @pharmonie with this new driver. I am trying to use the Arduino IDE with a Sparkfun redboard but am completely blocked by this issue. Are there any workarounds?

Graham Lindsay:
I downloaded and installed the new v2_4_4 driver on a 2020 MacBook Air running Catalina 10.15.6 (on the day it became available).

The new installer ran (I did have to give specific permission in System Preferences) and completed the installation.  After the install I could properly communicate with the virtual serial port.

This was a welcome relief since my previous attempts to install the v2_4_2 driver on this machine, with earlier versions of Catalina initially appeared to have worked, but I had not been able to communication with the device, which in my case was a USB-interfaced Digi X-Stream radio modem.

This new driver also worked for me. It turns out I was using a charging only USB cable  :-[


[0] Message Index

[#] Next page

Go to full version