FTDI Community

Please login or register.

Login with username, password and session length.
Advanced Search  

News:

Welcome to the FTDI Community!

Please read our Welcome Note

Technical Support enquires
please contact the team
@ FTDI Support


New Bridgetek Community is now open

Please note that we have created the Bridgetek Community to discuss all Bridgetek products e.g. EVE, MCU.

Please follow this link and create a new user account to get started.

Bridgetek Community

Author Topic: VCN1L Bootloader wiped/corrupted  (Read 138 times)

KBridges

  • Newbie
  • *
  • Posts: 1
    • View Profile
VCN1L Bootloader wiped/corrupted
« on: November 04, 2020, 11:00:05 AM »

Hi All,

Could anyone give me any ideas as to why the bootloader would disappear or corrupt on the VNC1L?

Thank you in advance.
« Last Edit: November 05, 2020, 10:26:56 AM by KBridges »
Logged

FTDI Community

  • Administrator
  • Hero Member
  • *****
  • Posts: 507
    • View Profile
Re: VCN1L Bootloader wiped/corrupted
« Reply #1 on: November 06, 2020, 04:40:50 PM »

Hello,

Why do you think the bootloader has disappeared or corrupted?

To enable the bootloader, the PROG# pin must be driven low and the VNC1L must then be reset by driving the RESET# pin low then high. Run mode can be enabled by driving the PROG# pin high and then resetting the VNC1L by driving the RESET# pin low then high.

Refer to ANVNC1L-01 Vinculum VNC1L Bootloader for more information.

The Vinculum Firmware User Manual also details programming options in section 3.1.3.

It would be worthwhile connecting a 3.3V TTL cable to the VNC1L and using FT_PROG to try and reprogram the VDAP firmware found here:

https://www.ftdichip.com/Firmware/Precompiled.htm

This is not a common issue that other community users could help with.
You might want to contact your local support team:

https://www.ftdichip.com/FTContact.htm

Best Regards,
FTDI Community
Logged