FTDI Community

Please login or register.

Login with username, password and session length.
Advanced Search  

News:

Welcome to the FTDI Community!

Please read our Welcome Note

Technical Support enquires
please contact the team
@ FTDI Support


New Bridgetek Community is now open

Please note that we have created the Bridgetek Community to discuss all Bridgetek products e.g. EVE, MCU.

Please follow this link and create a new user account to get started.

Bridgetek Community

Author Topic: Programming Altera Cyclone II using FT232H  (Read 79 times)

Anshumantech

  • Newbie
  • *
  • Posts: 12
    • View Profile
Programming Altera Cyclone II using FT232H
« on: February 04, 2021, 05:19:43 AM »

Hello,

 

I have made PCB module using FT232H, and trying to program Altera Cyclone II and Cyclone IV using UrJTAG.

Initially both devices were not detecting so I tried with BSDL files still devices were  not detecting.

While testing Cyclone II, there was a message "TDO seems to be stuck at 1", but all connections are in well manner on hardware (not shorted to another pin). I was checking voltage levels of TCK, TDI, TDO and TMS. But when I connect DMM +ve port to TCK pin and common  to ground Cyclone II started detecting. On all Voltage levels of DMM it get detected. This happens only for TCK pin.

Why this is happening?

I also tried to programming Xilinx Spartan 3, Spartan 6 devices it detects and programs successfully without any additional thing like connecting DMM.

Comment on this. 
Logged