FTDI Community

Please login or register.

Login with username, password and session length.
Advanced Search  

News:

Welcome to the FTDI Community!

Please read our Welcome Note

Technical Support enquires
please contact the team
@ FTDI Support


New Bridgetek Community is now open

Please note that we have created the Bridgetek Community to discuss all Bridgetek products e.g. EVE, MCU.

Please follow this link and create a new user account to get started.

Bridgetek Community

Author Topic: COM port not appearing  (Read 167 times)

AlwaysBufferGhz

  • Newbie
  • *
  • Posts: 1
    • View Profile
COM port not appearing
« on: February 23, 2021, 04:33:02 PM »

Hi,

On Windows 7 I have a device using the FT232RL (maybe generic) serial port which is a native windows driver. Unfortunately, someone deleted the USB composite serial converter, checked "delete the driver software for this device" and now the COM port or serial converter will not appear in device manager when a reboot is performed.

I have downloaded the drivers on the website, extracted them, and directed them to search for the drivers however the searching bar does not stop searching.
Logged

FTDI Community

  • Administrator
  • Hero Member
  • *****
  • Posts: 591
    • View Profile
Re: COM port not appearing
« Reply #1 on: February 24, 2021, 04:19:18 PM »

Hello,

Which OS are you using?

Can you please use Microsoft USBView to check the details of the hardware that you are using?
Make sure the config descriptors option is selected (Options menu) and you may press F5 to refresh.
Now select the device that is highlighted by the exclamation mark, if applicable.
The idVendor and idProduct numbers are of interest.
Please include all the information in your reply like this:

Code: [Select]
Device Descriptor:
bcdUSB:             0x0200
bDeviceClass:         0x00
bDeviceSubClass:      0x00
bDeviceProtocol:      0x00
bMaxPacketSize0:      0x08 (8)
idVendor:           0x0403 (Future Technology Devices International Limited)
idProduct:          0x6001
bcdDevice:          0x0600
iManufacturer:        0x01
0x0409: "FTDI"
iProduct:             0x02
0x0409: "USB <-> Serial Converter"
0x0409: "USB <-> Serial Converter"
iSerialNumber:        0x03
0x0409: "FT123456"
bNumConfigurations:   0x01
.
.
.

Have you also tried pre-installing the driver on the PC with our setup executable?
Note that you can also point to the 2.12.28 drivers in Device Manager.

Also refer to the Installation Guides.

Best Regards,
FTDI Community
Logged