FTDI Community

Please login or register.

Login with username, password and session length.
Advanced Search  


Welcome to the FTDI Community!

Please read our Welcome Note

Technical Support enquires
please contact the team
@ FTDI Support

New Bridgetek Community is now open

Please note that we have created the Bridgetek Community to discuss all Bridgetek products e.g. EVE, MCU.

Please follow this link and create a new user account to get started.

Bridgetek Community

Author Topic: Unable to Get the Clock Pulses when Connected via FTDI  (Read 1413 times)

Siddharth Mishra

  • Newbie
  • *
  • Posts: 4
    • View Profile
Unable to Get the Clock Pulses when Connected via FTDI
« on: September 24, 2021, 03:09:14 PM »

Hi Team,

We are working on a project with Custom Designed  Board having an MCU of KS20/22 series by NXP  connected to FT2232H Chip through a Multiplexer. We are using an API using the LibMPSSE library provided by FTDI ( https://ftdichip.com/software-examples/mpsse-projects/libmpsse-spi-examples/ ) on our PC Machine running Linux OS and tried to run the code on the board sending the data over SPI channel, In the entire process we failed to get the Clock Pulses when tried to measure on the MCU side of the Pin which to be particular was tested upon TP-44 as shown in the Schematic.

FTDI Community

  • Administrator
  • Hero Member
  • *****
  • Posts: 800
    • View Profile
Re: Unable to Get the Clock Pulses when Connected via FTDI
« Reply #1 on: September 27, 2021, 01:45:00 PM »


I see the multiplexer you are using has two output channels for each input. are you sure you have configured them correctly, for the clock signal to come out on 2B1? have you tried to see if the signal is on 2B2?

Best regards

FTDI community