General Category > Discussion - Hardware

FT232H Non-Responsive in Design -- Running Out of Ideas


Hello all!  I am working on a PCB design (open source here, the FT232H is on page 3) which uses an FT232H to provide USB to SPI/I2C/UART conversion.  I've been testing the first board for some time, and have been unable to get any response out of the FT232H chip.  I see that it's outputting power on the VPHY and VPLL pins, but it has not been responsive over the USB interface -- both USB pins seem to be stuck floating.

The elephant in the room with my design is that I didn't provide an EEPROM for the FT232H, since the datasheet indicates it's not required (this board will only be used internally and I don't need to use a custom VID/PID or any permanent configuration).  However, I couldn't find any examples whatsoever of how to connect the EEPROM pins when there isn't an EEPROM on the board, so I wasn't entirely sure what to do.  Originally I tried pulling EEDATA low, and then I tried reworking the board to pull all three EEPROM pins high, but neither seemed to produce a response.

Things I have tried so far:

* Pulling pin 31 (ACBUS7/PWRSAV#) high in case the chip is in sleep mode (even though the datasheet indicates that this function is disabled without an EEPROM
* Replacing the chip on the board
* Pulling all the EEPROM pins high
* Cutting the traces from the internal USB hub and bodge soldering on a USB cable direct to my PC (so I can rule out the internal hub)
* Measuring voltages on every pin.  I don't remember the exact results but there was nothing that seemed abnormal (except that, when I had the pulldown on EEDATA, it was at like 0.4V
* Attaching a 1Ghz logic analyzer to the USB traces.  Did not observe any activity other than the host device trying fruitlessly to reset the FT232H
After all this, I'm about out of ideas.  Does anyone know if there's anything special I need to do to get the FT232H to work without an EEPROM attached?  Are there any other troubleshooting steps I can do to diagnose the issue?  I'm just about to give up and redesign with a competitor chip (CY7C65211), so any tips would be appreciated!

FTDI Community:

could you please email your schematic to we can then review it for you to see if there is anything that could be causing your issue.

Best regards
FTDI Community

As an update, the support people reviewed my schematic, and found an issue -- an EEPROM is actually required for the FT232H's self powered operation mode, because you have to configure the chip to self powered in the EEPROM.  Also, ACBUS7 should be set so that the pin is pulled up  to 3.3V when USB VBUS is active.

That said, this still doesn't explain why it wouldn't enumerate on my board after the reworks, and I think I may have to give up on this chip for now.


[0] Message Index

Go to full version