FTDI Community

Please login or register.

Login with username, password and session length.
Advanced Search  

News:

Welcome to the FTDI Community!

Please read our Welcome Note

Technical Support enquires
please contact the team
@ FTDI Support


New Bridgetek Community is now open

Please note that we have created the Bridgetek Community to discuss all Bridgetek products e.g. EVE, MCU.

Please follow this link and create a new user account to get started.

Bridgetek Community

Author Topic: FTDI Port cannot be displayed under the ports (COM and LPT) of Device Manager  (Read 6051 times)

sunlite

  • Newbie
  • *
  • Posts: 2
    • View Profile

Hello,

Have to ask technical experts a question. We use your prestigious company's FT232 for communication between master and slave computers through USB to RS232 serial port. We used the driver of FTDI, but we customized it our own driver by wrapping it outside of FTDI. Our drivers mainly include two inf files: FTDI Bus and FTDI Port. The matter is that the device manager is unable to recognize the COM port. Our Port cannot be displayed under the ports (COM and LPT) of device manager.
Currently, it can only be displayed on 2 sets of ASUS laptops ( Windows 11 Home Chinese version , Intel Core i3, X64) under the device manager ports (COM and LPT) . Tried other brands like Lenovo, Hua wei, Dell, Hassee, Haier,  even if other same model of ASUS laptops but all failed, it won't work. Including desktop computers. This problem has been troubling us and we stuck here for a long time and needs to be solved urgently. Otherwise, the Labview program that is nearly finished will be unable to deploy to the client's machine due to this driver issue!

Please help, the sooner, the better!  :)
Thank you very much!

sunlight
Logged

FTDI Community

  • Administrator
  • Hero Member
  • *****
  • Posts: 906
    • View Profile

Hi,

Could you please contact your local support line at: cn.support@ftdichip.com. They will be able to help you.

Best Regards
FTDI Community
Logged

sunlite

  • Newbie
  • *
  • Posts: 2
    • View Profile

Yes. I sent email to China support. They are helping us now. :)
BTW Just put the hard disk of my Development ASUS laptop to another same model ASUS laptop and then the later ASUS laptop could recognize the COM port and run my project as on my Development ASUS laptop. This could just temporarily solve the problem. But not long term and ultimate solution.

thanks
« Last Edit: May 27, 2024, 04:33:48 am by sunlite »
Logged