FTDI Community

General Category => Discussion - Hardware => Topic started by: Anshumantech on February 04, 2021, 05:19:43 AM

Title: Programming Altera Cyclone II using FT232H
Post by: Anshumantech on February 04, 2021, 05:19:43 AM


I have made PCB module using FT232H, and trying to program Altera Cyclone II and Cyclone IV using UrJTAG.

Initially both devices were not detecting so I tried with BSDL files still devices were  not detecting.

While testing Cyclone II, there was a message "TDO seems to be stuck at 1", but all connections are in well manner on hardware (not shorted to another pin). I was checking voltage levels of TCK, TDI, TDO and TMS. But when I connect DMM +ve port to TCK pin and common  to ground Cyclone II started detecting. On all Voltage levels of DMM it get detected. This happens only for TCK pin.

Why this is happening?

I also tried to programming Xilinx Spartan 3, Spartan 6 devices it detects and programs successfully without any additional thing like connecting DMM.

Comment on this.