FTDI Community

Please login or register.

Login with username, password and session length.
Advanced Search  

News:

Welcome to the FTDI Community!

Please read our Welcome Note

Technical Support enquires
please contact the team
@ FTDI Support


New Bridgetek Community is now open

Please note that we have created the Bridgetek Community to discuss all Bridgetek products e.g. EVE, MCU.

Please follow this link and create a new user account to get started.

Bridgetek Community

Author Topic: ftd2xx on raspberry pi not sending and acting like it continuously receives.  (Read 128 times)

rpinoob

  • Newbie
  • *
  • Posts: 1
    • View Profile


Hello,

I installed the ftdxx drivers on a rpi. When i have a device plugged in it acts as if it is continuously receiving data. I tried V7 and two v6 drivers. They all act the same. For example when i run the "simple" example with a loopback connection I get this result:

.....
0x0F, 0x0F, 0x0F, 0x0F, 0x0F, 0x0F, 0x0F, 0x0F, 0x0F, 0x0F, 0x0F, 0x0F, 0x0F
Error: read-buffer does not match write-buffer.

Hope someone has a helpfull tip
Logged

FTDI Community

  • Administrator
  • Sr. Member
  • *****
  • Posts: 348
    • View Profile

Hello,

Which FTDI chip part number do you have and what hardware circuit are you using?

You could try connecting it to a Windows PC via either VCP (e.g. a terminal) or D2xx to see if the hardware itself is sending back characters.

Loopback examples are suited to UART applications but if your chip is a parallel one (such as FT245R) then it needs to be connected to a suitable device (such as an FPGA or MCU) on the parallel side which will read the data and write it back in as the parallel interface does not directly allow loopback.

Also check for the RxD line (if UART) or the write strobe (if parallel) being held in the active state by the external circuit as this can result in data being sent to the PC.

Best Regards,
FTDI Community

Logged