FTDI Community

Please login or register.

Login with username, password and session length.
Advanced Search  

News:

Welcome to the FTDI Community!

Please read our Welcome Note

Technical Support enquires
please contact the team
@ FTDI Support


New Bridgetek Community is now open

Please note that we have created the Bridgetek Community to discuss all Bridgetek products e.g. EVE, MCU.

Please follow this link and create a new user account to get started.

Bridgetek Community

Author Topic: FT232H not seen by Windows 10  (Read 1207 times)

MF3

  • Newbie
  • *
  • Posts: 3
    • View Profile
FT232H not seen by Windows 10
« on: April 26, 2021, 11:35:38 AM »

Hello community!

I have an issue with FT232H. It's used as USB-232 interface and lately we started to have problems on Windows 10 machines: the device is totally not detected (no "usb inserted sound", no changes in Device Manager, no device detected in FT-Prog). The only sign that the converter is plugged in can be found in USBView, where, if continuously refreshing, sometimes a "USB Streaming" appears in the position where the converter is plugged. Unfortunately all the parameters of this random popping device are zero, so it's not very useful.

On the other hand, on a Windows 7 machine, the device is correctly detected by Windows and all the other applications. One thing i noticed is the FT232H converter could not be programmed, FT-Prog says something like "Can't program, device removed?".
[EDIT] Opening the device I saw the EEPROM was not implemented, so the FT232H runs its default mode.

Usb descriptors change in a coherent way (being it a different chip) aside, maybe, from power demand, where FT232BL presents itself as bus/self powered with 90mA and FT232H as bus powered with 500mA. But maybe it's right!

I also saw that the info in FT-Prog were different from those in USBView (e.g. the descriptor string of FT232H on FT-Prog is "USB <-> SERIAL" where in USBView and in Devices/Printers is "SINGLE RS232-HS".

Can someone give me some pointers about this problem?
Thank you in advance, have a nice day!

MF3
« Last Edit: April 27, 2021, 11:57:32 AM by MF3 »
Logged

MF3

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: FT232H not seen by Windows 10
« Reply #1 on: April 27, 2021, 09:45:37 AM »

Hello again!

I made some measures on the usb line and the data "exchange" is strange. On the FT232H datasheet I read that it's a FS/HS device so I expected both types of waveforms. If the device is connected to the windows 7 computer, it works as expected: pull up, device descriptors requests, and keep alive, all at 3 volt. The attachment shows (poorly, sorry) the D+ D- waveforms when communicating with my Windows 10 machine.  I expected to see 3V amplitude like with the previous PC. The amplitude of the small signal is around 600mV and it looks like a J-K pattern, like it's trying to configure for High Speed but without success.
When the USB is plugged in, I see the D+ line pulled up but it immediately starts behaving as the attachment shows.

There is a way to "force" Full Speed on windows or on the pcb?

« Last Edit: April 27, 2021, 10:26:39 AM by MF3 »
Logged

MF3

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: FT232H not seen by Windows 10
« Reply #2 on: April 27, 2021, 12:56:26 PM »

Further analyses of the schematic revealed 100R in series with D+ and D- lines for ESD protection, value too high for High Speed USB.
We'll run some tests for a suitable value. With no resistors in series works fine.
Logged

FTDI Community

  • Administrator
  • Hero Member
  • *****
  • Posts: 612
    • View Profile
Re: FT232H not seen by Windows 10
« Reply #3 on: April 27, 2021, 04:26:28 PM »

Hello,

It sounds like you are having some custom hardware problems.
If all the parameters in USBView are zero, this points to a hardware issue.

You can send details to your local support team including your hardware schematic:

https://ftdichip.com/technical-support/

We can perform a review of the complete design to look for all issues.

Please see AN_146 USB Hardware Design Guidelines for FTDI ICs.
The USB data lines should have zero to 10ohm resistors for edge rate control.
On our UM232H module, it has 0ohm resistors fitted.
On our UM232H-B module, it has 10ohm resistors fitted.
You can use these known good modules as a reference.

Note that 'SINGLE RS232-HS' is the default description if you do not have an external EEPROM fitted.

This is a High Speed USB device and will operate at USB High Speed.
It can also operate at Full Speed (12Mbits/second).

A full speed USB device (12Mbps) uses a 1k5 pull-up resistor to VCC on the USB DP signal line. This is integrated in the design.

A high speed USB device (480Mbps) will initially appear as a full speed device to the host. The first thing the USB host does is to attempt to send /receive packets at high speed to the USB device. This is known as J and K chirp and if communication is successful it will be assumed that the USB device is a high speed device. If this initial communication fails then the USB host assumes that the device is a full speed device.
This means a high speed device has a 1k5 pull up resistor on USB DP that can be switched in / out of circuit.

You can’t control Full / High Speed operation in the IC.

Best Regards,
FTDI Community
Logged