FTDI Community

Please login or register.

Login with username, password and session length.
Advanced Search  


Welcome to the FTDI Community!

Please read our Welcome Note

Technical Support enquires
please contact the team
@ FTDI Support

New Bridgetek Community is now open

Please note that we have created the Bridgetek Community to discuss all Bridgetek products e.g. EVE, MCU.

Please follow this link and create a new user account to get started.

Bridgetek Community

Author Topic: Ham Transceiver INOP  (Read 22815 times)


  • Newbie
  • *
  • Posts: 1
    • View Profile
Ham Transceiver INOP
« on: August 17, 2022, 06:18:20 pm »


   I am trying to remote control my Yaesu FTDX10 ham transceiver via USB.  It has 3 USB items in it - an audio card, and two serial ports.  The serial ports seem to be supplied by
an FTDI CP2105-F01-GM chip.  At least that's what I see in the schematic.

  On my Windows 10 box....   

   Standard ham radio software only finds the audio card.  In device manager, I only see
COM2 and COM3, which are built-in ports on the motherboard.  And also a "USB Composite Device" with hardware IDs of 08BB:29C3, which correspond to a TI audio CODEC.
  I have tried installing various versions of the FTDI driver both from the FTDI website and the Windows Update catalog.  No joy.  It's as if the FTDI device doesn't exist.  I have also tried unplugging the radio from my USB3 hub and plugging it directly into the computer, also no joy.

  I have also tried uninstalling the USB composite device, unplugging & plugging so

   The pc is: 

Processor   Intel(R) Xeon(R) W-1250 CPU @ 3.30GHz   3.31 GHz
Installed RAM   32.0 GB (31.8 GB usable)
Device ID   D9BA5DC5-8D67-4060-A17D-86AD38443D63
Product ID   00326-10000-00000-AA385
System type   64-bit operating system, x64-based processor

And the Windows is:
Edition   Windows 10 Home
Version   21H2
Installed on   ‎1/‎24/‎2021
OS build   19044.1889
Experience   Windows Feature Experience Pack 120.2212.4180.0

... This may all be moot.  I hooked up the radio to a laptop running Ubuntu Linux.
Lsusb gives me the following devices when the radio USB is plugged in:

08BB:29C3 Texas Instruments PCM2093C Audio Codec
0424:2512 Microchip Technologies USB 2.0 Hub

No FTDI anything.

... So it might just be a problem in the radio.  Which is really bad news.  I do NOT want to
get into that thing.

FTDI Community

  • Administrator
  • Hero Member
  • *****
  • Posts: 906
    • View Profile
Re: Ham Transceiver INOP
« Reply #1 on: August 18, 2022, 04:27:01 pm »


Please note that the CP2105 is not from FTDI but from Silicon Labs.

Since this is not one of our products, although it utilises our device, I am unable to support it.
Product Manufacturers are responsible for supporting end-users of their products, so you will need to contact the OEM.
FTDI cannot control how the USB ICs are used and often has no knowledge of the entire product.
Please see the following document for reference:


Best Regards,
FTDI Community